GetValidSymbols Method (ForgeTypeId)


Format Options Get Valid Symbols(Forge Type Id) Method

Gets the identifiers of all valid symbols for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<ForgeTypeId> GetValidSymbols(
	ForgeTypeId unitTypeId
)

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.

Return Value

IList ForgeTypeId
Identifiers of the valid symbols.
Exceptions
Exception Condition
ArgumentException unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException A non-optional argument was null
See Also