CreateConduitConnector Method (Document, Reference, Edge)


Create a new conduit ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static ConnectorElement CreateConduitConnector(
	Document document,
	Reference planarFace,
	Edge edge
)
Visual Basic
Public Shared Function CreateConduitConnector ( _
	document As Document, _
	planarFace As Reference, _
	edge As Edge _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateConduitConnector(
	Document^ document, 
	Reference^ planarFace, 
	Edge^ edge
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document to add the connector to.
planarFace
Type: Autodesk.Revit.DBReference
The planar face to place the connector on.
edge
Type: Autodesk.Revit.DBEdge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

The conduit ConnectorElement.

Remarks

Regenerates the document.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Connector creation is not allowed in this family.

See Also