Connector |
Create a new conduit ConnectorElement.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ConnectorElement CreateConduitConnector(
Document document,
Reference planarFace,
Edge edge
)
Parameters
- document Document
- The document to add the connector to.
- planarFace Reference
- The planar face to place the connector on.
- edge Edge
- One of the edges in the edge loop that defines the connector location on the planar face.
Return Value
ConnectorElementThe conduit ConnectorElement.

Exception | Condition |
---|---|
ArgumentException | The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Connector creation is not allowed in this family. |

Regenerates the document.