SetFilterVisibility Method


Sets the visibility of the elements associated with a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public void SetFilterVisibility(
	ElementId filterElementId,
	bool visibility
)
Visual Basic
Public Sub SetFilterVisibility ( _
	filterElementId As ElementId, _
	visibility As Boolean _
)
Visual C++
public:
void SetFilterVisibility(
	ElementId^ filterElementId, 
	bool visibility
)

Parameters

filterElementId
Type: Autodesk.Revit.DBElementId
The ElementId of the filter.
visibility
Type: SystemBoolean
True if the elements associated with the filter are visible in the view, false otherwise.

Remarks

If the filter is not currently applied to the view, this will add the filter with the specified visibility.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException ElementId is not associated with a FilterElement.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also