SetFilterVisibility Method


View Set Filter Visibility Method

Sets the visibility of the elements associated with a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetFilterVisibility(
	ElementId filterElementId,
	bool visibility
)

Parameters

filterElementId ElementId
The ElementId of the filter.
visibility Boolean
True if the elements associated with the filter are visible in the view, false otherwise.
Exceptions
Exception Condition
ArgumentException ElementId is not associated with a FilterElement.
ArgumentNullException A non-optional argument was null
InvalidOperationException The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
Remarks
If the filter is not currently applied to the view, this will add the filter with the specified visibility.
See Also