ElementIntersectsSolidFilter Constructor (Solid, Boolean)


Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public ElementIntersectsSolidFilter(
	Solid solid,
	bool inverted
)
Visual Basic
Public Sub New ( _
	solid As Solid, _
	inverted As Boolean _
)
Visual C++
public:
ElementIntersectsSolidFilter(
	Solid^ solid, 
	bool inverted
)

Parameters

solid
Type: Autodesk.Revit.DBSolid
The solid geometry to check for intersection.
inverted
Type: SystemBoolean
True if the filter should match all elements which do not intersect the given element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also