ElementIntersectsSolidFilter Constructor (Solid, Boolean)


Element Intersects Solid Filter(Solid, Boolean) Constructor

Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementIntersectsSolidFilter(
	Solid solid,
	bool inverted
)

Parameters

solid Solid
The solid geometry to check for intersection.
inverted Boolean
True if the filter should match all elements which do not intersect the given element.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also