Identifies whether the given point exists in the topography surface.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- point
- Type: Autodesk.Revit.DBXYZ
The point to be checked.
Return Value
True if the input point exists in the topography surface, otherwise false.Remarks
The given point will be evaluated in XYZ. If a point matches the XY location, but not the elevation, this function still returns false. This applies to TopographySurface and SiteSubRegion elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |