Topography |
Identifies whether the given point exists in the topography surface.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- point XYZ
- The point to be checked.
Return Value
BooleanTrue if the input point exists in the topography surface, otherwise false.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The given point will be evaluated in XYZ. If a point matches the XY location, but not the elevation, this function still returns false. This applies to TopographySurface and SiteSubRegion elements.