IsElementSupported Method


Identifies if the input element is supported by element intersection filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static bool IsElementSupported(
	Element element
)
Visual Basic
Public Shared Function IsElementSupported ( _
	element As Element _
) As Boolean
Visual C++
public:
static bool IsElementSupported(
	Element^ element
)

Parameters

element
Type: Autodesk.Revit.DBElement
The element.

Return Value

True if the element is supported, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also