SetReportsFolder Method


Sets the reports folder path.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public void SetReportsFolder(
	string folderPath
)
Visual Basic
Public Sub SetReportsFolder ( _
	folderPath As String _
)
Visual C++
public:
void SetReportsFolder(
	String^ folderPath
)

Parameters

folderPath
Type: SystemString
The string to specify the path. It may include the special label for project name.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException A folder path cannot contain special characters.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also