Creates a vertically compound CompoundStructure with one layer.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- sampleHeight
- Type: SystemDouble
The sample height of this vertically compound structure.
- layerFunction
- Type: Autodesk.Revit.DBMaterialFunctionAssignment
The function of the single layer.
- width
- Type: SystemDouble
The width of the single layer.
- materialId
- Type: Autodesk.Revit.DBElementId
The ElementId of the material for the single layer.
Return Value
The newly created compound structure.Remarks
It is not verified that materialId corresponds to a valid MaterialElem.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The given value for sampleHeight must be greater than 0 and no more than 30000 feet. -or- The given value for width must be greater than 0 and no more than 30000 feet. -or- A value passed for an enumeration argument is not a member of that enumeration |