Compound |
Creates a vertically compound CompoundStructure with one layer.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static CompoundStructure CreateSingleLayerCompoundStructure(
double sampleHeight,
MaterialFunctionAssignment layerFunction,
double width,
ElementId materialId
)
Parameters
- sampleHeight Double
- The sample height of this vertically compound structure.
- layerFunction MaterialFunctionAssignment
- The function of the single layer.
- width Double
- The width of the single layer.
- materialId ElementId
- The ElementId of the material for the single layer.
Return Value
CompoundStructureThe newly created compound structure.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The given value for sampleHeight must be greater than 0 and no more than 30000 feet. -or- The given value for width must be greater than 0 and no more than 30000 feet. -or- A value passed for an enumeration argument is not a member of that enumeration |

It is not verified that materialId corresponds to a valid MaterialElem.