SetSpatialElementBoundaryLocation Method


Sets the spatial element boundary location of a spatial element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public void SetSpatialElementBoundaryLocation(
	SpatialElementBoundaryLocation spatialElementBoundaryLocation,
	SpatialElementType spType
)
Visual Basic
Public Sub SetSpatialElementBoundaryLocation ( _
	spatialElementBoundaryLocation As SpatialElementBoundaryLocation, _
	spType As SpatialElementType _
)
Visual C++
public:
void SetSpatialElementBoundaryLocation(
	SpatialElementBoundaryLocation spatialElementBoundaryLocation, 
	SpatialElementType spType
)

Parameters

spatialElementBoundaryLocation
Type: Autodesk.Revit.DBSpatialElementBoundaryLocation
The boundary location.
spType
Type: Autodesk.Revit.DBSpatialElementType
The spatial element type.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Currently only SpatialElementType.Room is permitted when setting the boundary location.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also