Area |
Sets the spatial element boundary location of a spatial element type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetSpatialElementBoundaryLocation(
SpatialElementBoundaryLocation spatialElementBoundaryLocation,
SpatialElementType spType
)
Parameters
- spatialElementBoundaryLocation SpatialElementBoundaryLocation
- The boundary location.
- spType SpatialElementType
- The spatial element type.

Exception | Condition |
---|---|
ArgumentException | Currently only SpatialElementType.Room is permitted when setting the boundary location. |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |