GetConnectedWalls Method


Obtains the IFC-specific information regarding the connections between this wall and other elements.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static IList<IFCConnectedWallData> GetConnectedWalls(
	Wall pWallElem,
	IFCConnectedWallDataLocation locaction
)
Visual Basic
Public Shared Function GetConnectedWalls ( _
	pWallElem As Wall, _
	locaction As IFCConnectedWallDataLocation _
) As IList(Of IFCConnectedWallData)
Visual C++
public:
static IList<IFCConnectedWallData^>^ GetConnectedWalls(
	Wall^ pWallElem, 
	IFCConnectedWallDataLocation locaction
)

Parameters

pWallElem
Type: Autodesk.Revit.DBWall
The wall.
locaction
Type: Autodesk.Revit.DB.IFCIFCConnectedWallDataLocation
The location on the wall from where the connections should be obtained. This should be either IFCConnectedWallDataLocation.Start or IFCConnectedWallDataLocation.End.

Return Value

The connection information.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also