Exporter |
Obtains the IFC-specific information regarding the connections between this wall and other elements.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public static IList<IFCConnectedWallData> GetConnectedWalls(
Wall pWallElem,
IFCConnectedWallDataLocation locaction
)
Parameters
- pWallElem Wall
- The wall.
- locaction IFCConnectedWallDataLocation
- The location on the wall from where the connections should be obtained. This should be either IFCConnectedWallDataLocation.Start or IFCConnectedWallDataLocation.End.
Return Value
IList IFCConnectedWallDataThe connection information.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |