GetSegmentById Method


Gets the analytical segment with the specified id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public MEPAnalyticalSegment GetSegmentById(
	int segmentId
)
Visual Basic
Public Function GetSegmentById ( _
	segmentId As Integer _
) As MEPAnalyticalSegment
Visual C++
public:
MEPAnalyticalSegment^ GetSegmentById(
	int segmentId
)

Parameters

segmentId
Type: SystemInt32
The segment id to be retrieved. This id is not 0 based.

Return Value

The returned analytical segment.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input must be a valid segment id.

See Also