GetSegmentById Method


MEPAnalytical Model Data Get Segment By Id Method

Gets the analytical segment with the specified id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public MEPAnalyticalSegment GetSegmentById(
	int segmentId
)

Parameters

segmentId Int32
The segment id to be retrieved. This id is not 0 based.

Return Value

MEPAnalyticalSegment
The returned analytical segment.
Exceptions
Exception Condition
ArgumentException The input must be a valid segment id.
See Also