BoundingBoxContainsPointFilter Constructor (XYZ, Double, Boolean)


Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria. This constructor includes the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public BoundingBoxContainsPointFilter(
	XYZ point,
	double tolerance,
	bool inverted
)
Visual Basic
Public Sub New ( _
	point As XYZ, _
	tolerance As Double, _
	inverted As Boolean _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
	XYZ^ point, 
	double tolerance, 
	bool inverted
)

Parameters

point
Type: Autodesk.Revit.DBXYZ
The point used to find elements with a bounding box containing it.
tolerance
Type: SystemDouble
The tolerance value to use instead of zero. See the tolerance property for details.
inverted
Type: SystemBoolean
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also