BoundingBoxContainsPointFilter Constructor (XYZ, Double, Boolean)


Bounding Box Contains Point Filter(XYZ, Double, Boolean) Constructor

Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria. This constructor includes the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public BoundingBoxContainsPointFilter(
	XYZ point,
	double tolerance,
	bool inverted
)

Parameters

point XYZ
The point used to find elements with a bounding box containing it.
tolerance Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted Boolean
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.
Exceptions
Exception Condition
ArgumentException The given value for tolerance is not finite -or- The given value for tolerance is not a number
ArgumentNullException A non-optional argument was null
See Also