Sets Reveal Obstacles mode for the given view.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- DBView
- Type: Autodesk.Revit.DBView
The view to set Reveal Obstacles mode for.
- newState
- Type: SystemBoolean
New state of Reveal Obstacles mode to be set for the view.
Return Value
Result status of the operation.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The Path of Travel calculation service is not available |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing DBView is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document containing DBView has no open transaction. |