Path |
Sets Reveal Obstacles mode for the given view.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static PathOfTravelCalculationStatus SetRevealObstaclesMode(
View DBView,
bool newState
)
Parameters
- DBView View
- The view to set Reveal Obstacles mode for.
- newState Boolean
- New state of Reveal Obstacles mode to be set for the view.
Return Value
PathOfTravelCalculationStatusResult status of the operation.

Exception | Condition |
---|---|
ArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The Path of Travel calculation service is not available |
ModificationForbiddenException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing DBView is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document containing DBView has no open transaction. |