Writes a PartAtom XML from the contents of a family object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- xmlFilePath
- Type: SystemString
The xml file to be saved.
Remarks
This method is designed for a family loaded into a document in session. So it will skip the type catalog file. To extract the PartAtom XML from a family file on disk, use Application.ExtractPartAtomFromFamilyFile()
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | If 'xmlFilePath' is a null reference (Nothing in Visual Basic) or an empty string. |