ExtractPartAtom Method


Family Extract Part Atom Method

Writes a PartAtom XML from the contents of a family object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ExtractPartAtom(
	string xmlFilePath
)

Parameters

xmlFilePath String
The xml file to be saved.
Exceptions
Exception Condition
ArgumentException If 'xmlFilePath' is or an empty string.
Remarks
This method is designed for a family loaded into a document in session. So it will skip the type catalog file. To extract the PartAtom XML from a family file on disk, use Application.ExtractPartAtomFromFamilyFile()
See Also