PresetInitialColor Constructor (ColorPreset)


Creates an initial color preset object with the given preset value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public PresetInitialColor(
	ColorPreset presetIn
)
Visual Basic
Public Sub New ( _
	presetIn As ColorPreset _
)
Visual C++
public:
PresetInitialColor(
	ColorPreset presetIn
)

Parameters

presetIn
Type: Autodesk.Revit.DB.LightingColorPreset
The enum value which determines the preset value

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also