IsWallJoinAllowedAtEnd Method


Identifies if the indicated end of the wall allows joins or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static bool IsWallJoinAllowedAtEnd(
	Wall wall,
	int end
)
Visual Basic
Public Shared Function IsWallJoinAllowedAtEnd ( _
	wall As Wall, _
	end As Integer _
) As Boolean
Visual C++
public:
static bool IsWallJoinAllowedAtEnd(
	Wall^ wall, 
	int end
)

Parameters

wall
Type: Autodesk.Revit.DBWall
The wall in question
end
Type: SystemInt32
0 or 1 for the beginning or end of the wall's curve

Return Value

true if it is allowed to join. false if it is disallowed.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also