IsAllowedDimensionStyle Method


Checks if the dimension style can be used with multi-reference annotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public bool IsAllowedDimensionStyle(
	ElementId dimensionStyleId
)
Visual Basic
Public Function IsAllowedDimensionStyle ( _
	dimensionStyleId As ElementId _
) As Boolean
Visual C++
public:
bool IsAllowedDimensionStyle(
	ElementId^ dimensionStyleId
)

Parameters

dimensionStyleId
Type: Autodesk.Revit.DBElementId
The dimension style to check.

Return Value

True if the dimension style can be used by multi-reference annotations.

Remarks

Only linear dimension styles are allowed.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also