RemoveReferenceObject Method (ExternalGeometryId)


Removes any reference object associated with the provided ExternalGeometryId from the DirectShapeType. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void RemoveReferenceObject(
	ExternalGeometryId externalId
)
Visual Basic
Public Sub RemoveReferenceObject ( _
	externalId As ExternalGeometryId _
)
Visual C++
public:
void RemoveReferenceObject(
	ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB ExternalGeometryId
The ExternalGeometryId of the reference object to be removed.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also