Direct |
Removes any reference object associated with the provided ExternalGeometryId from the DirectShapeType. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- externalId ExternalGeometryId
- The ExternalGeometryId of the reference object to be removed.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |