Check if the updater is optional or not.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- id
- Type: Autodesk.Revit.DBUpdaterId
Id of the updater to check
Return Value
Returns True if the updater is optional, False otherwise.Remarks
This flag controls whether an updater is going to be required next time a document in which it had been used is opened. If a non-optional updater is not found (currently not registered) in a document, the end user will be presented with a warning and choices to resolve the situation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Updater with this Id is not currently registered in Revit. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |