Updater |
Check if the updater is optional or not.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- id UpdaterId
- Id of the updater to check
Return Value
BooleanReturns True if the updater is optional, False otherwise.

Exception | Condition |
---|---|
ArgumentException | Updater with this Id is not currently registered in Revit. |
ArgumentNullException | A non-optional argument was null |

This flag controls whether an updater is going to be required next time a document in which it had been used is opened. If a non-optional updater is not found (currently not registered) in a document, the end user will be presented with a warning and choices to resolve the situation.