Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- planeReference
- Type: Autodesk.Revit.DBReference
A reference to some plane in the document. (Note: the reference must satisfy IsValidPlaneReference(), but this is not checked until this PointOnPlane object is assigned to a ReferencePoint.)
- position
- Type: Autodesk.Revit.DBUV
Coordinates of the point's projection onto the plane; see the Position property.
- xvec
- Type: Autodesk.Revit.DBUV
The direction of the point's X-coordinate vector in the plane's coordinates; see the XVec property. Optional; default value is (1, 0).
- offset
- Type: SystemDouble
Signed offset from the plane; see the Offset property.
Return Value
A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the input argument planeReference or position or xvec is a null reference (Nothing in Visual Basic) or offset is not a valid double value. |