Application New |
Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public PointOnPlane NewPointOnPlane(
Reference planeReference,
UV position,
UV xvec,
double offset
)
Parameters
- planeReference Reference
- A reference to some plane in the document. (Note: the reference must satisfy IsValidPlaneReference(), but this is not checked until this PointOnPlane object is assigned to a ReferencePoint.)
- position UV
- Coordinates of the point's projection onto the plane; see the Position property.
- xvec UV
- The direction of the point's X-coordinate vector in the plane's coordinates; see the XVec property. Optional; default value is (1, 0).
- offset Double
- Signed offset from the plane; see the Offset property.
Return Value
PointOnPlaneA new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument planeReference or position or xvec is or offset is not a valid double value. |