GetRotation Method


Gets the rotation angle in radians for the bending detail relative to its view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public static double GetRotation(
	Element bendingDetail
)
Visual Basic
Public Shared Function GetRotation ( _
	bendingDetail As Element _
) As Double
Visual C++
public:
static double GetRotation(
	Element^ bendingDetail
)

Parameters

bendingDetail
Type: Autodesk.Revit.DBElement
The bending detail for which we want to get the rotation.

Return Value

Returns the rotation angle in radians for the bending detail relative to its view.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also