Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- domain
- Type: Autodesk.Revit.DBConnectorDomainType
ConnectorDomainType to filter by. Pass ConnectorDomainType.Undefined to get all connector domains.
- shape
- Type: Autodesk.Revit.DBConnectorProfileType
ConnectorProfileType to filter by. Pass ConnectorProfileType.Invalid to get all shapes.
Return Value
All the fabrication connector identifiers, filtered by shape and domain. The return will be empty if no connectors are found.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |