GetAllFabricationConnectorDefinitions Method


Fabrication Configuration Get All Fabrication Connector Definitions Method

Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<int> GetAllFabricationConnectorDefinitions(
	ConnectorDomainType domain,
	ConnectorProfileType shape
)

Parameters

domain ConnectorDomainType
ConnectorDomainType to filter by. Pass ConnectorDomainType.Undefined to get all connector domains.
shape ConnectorProfileType
ConnectorProfileType to filter by. Pass ConnectorProfileType.Invalid to get all shapes.

Return Value

IList Int32
All the fabrication connector identifiers, filtered by shape and domain. The return will be empty if no connectors are found.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also