ProfileId Property


The profile id of the non-continuous rail, or invalidElementId if none.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2019

Syntax

C#
public ElementId ProfileId { get; set; }
Visual Basic
Public Property ProfileId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ ProfileId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: The profileId is not an Id of a valid NonContinuousRail profile.
Autodesk.Revit.ExceptionsArgumentNullException When setting this property: A non-optional argument was null

See Also