ProfileId Property


Non Continuous Rail Info Profile Id Property

The profile id of the non-continuous rail, or invalidElementId if none.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId ProfileId { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: The profileId is not an Id of a valid NonContinuousRail profile.
ArgumentNullException When setting this property: A non-optional argument was null
See Also