Gets the coordinate of a segment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- segmentId
- Type: SystemInt32
The id of a segment in this CompoundStructure.
Return Value
The local coordinates of the specified segment.Remarks
The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments. If the segment orientation is horizontal, then its coordinate will lie in the range [0.0, SampleHeight]. If the segment orientation is vertical, then its coordinate will lie in the range of u values obtained from GetRegionEnvelope(Int32).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The segment id is invalid. |
Autodesk.Revit.ExceptionsInvalidOperationException | This operation is valid only for vertically compound structures. |