Compound |
Gets the coordinate of a segment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- segmentId Int32
- The id of a segment in this CompoundStructure.
Return Value
DoubleThe local coordinates of the specified segment.

Exception | Condition |
---|---|
ArgumentException | The segment id is invalid. |
InvalidOperationException | This operation is valid only for vertically compound structures. |

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments. If the segment orientation is horizontal, then its coordinate will lie in the range [0.0, SampleHeight]. If the segment orientation is vertical, then its coordinate will lie in the range of u values obtained from GetRegionEnvelope(Int32) .