Sets Member Forces to Analytical Member.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- start
- Type: SystemBoolean
Member Forces position on Analytical Member. True for start, false for end.
- force
- Type: Autodesk.Revit.DBXYZ
The translational forces at specified position of the element. The x value of XYZ object represents force along x-axis of the Analytical Member coordinate system, y along y-axis, z along z-axis respectively.
- moment
- Type: Autodesk.Revit.DBXYZ
The rotational forces at specified position of the element. The x value of XYZ object represents moment about x-axis of the Analytical Member coordinate system, y about y-axis, z about z-axis respectively.
Remarks
If Analytical Member already have member forces defined for that end, newly provided values replace current one. Member forces are strictly related with releases. This means that setting member forces values is reasonable only for directions that have releases set to false.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |