SetMemberForces Method (Boolean, XYZ, XYZ)


Analytical Member Set Member Forces(Boolean, XYZ, XYZ) Method

Sets Member Forces to Analytical Member.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetMemberForces(
	bool start,
	XYZ force,
	XYZ moment
)

Parameters

start Boolean
Member Forces position on Analytical Member. True for start, false for end.
force XYZ
The translational forces at specified position of the element. The x value of XYZ object represents force along x-axis of the Analytical Member coordinate system, y along y-axis, z along z-axis respectively.
moment XYZ
The rotational forces at specified position of the element. The x value of XYZ object represents moment about x-axis of the Analytical Member coordinate system, y about y-axis, z about z-axis respectively.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
If Analytical Member already have member forces defined for that end, newly provided values replace current one. Member forces are strictly related with releases. This means that setting member forces values is reasonable only for directions that have releases set to false.
See Also