AddIntersectingReference Method


Adds intersecting reference with an offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public bool AddIntersectingReference(
	ElementId intersectingReference,
	double offset
)
Visual Basic
Public Function AddIntersectingReference ( _
	intersectingReference As ElementId, _
	offset As Double _
) As Boolean
Visual C++
public:
bool AddIntersectingReference(
	ElementId^ intersectingReference, 
	double offset
)

Parameters

intersectingReference
Type: Autodesk.Revit.DBElementId
Id of the new intersecting reference.
offset
Type: SystemDouble
The Offste for the new intersecting reference.

Return Value

True if the PartMaker did not already use this intersecting reference and it was added, false if the PartMaker already used this intersecting reference and this call only updated its offset.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The element id was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also