AddIntersectingReference Method


Part Maker Method To Divide Volumes Add Intersecting Reference Method

Adds intersecting reference with an offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool AddIntersectingReference(
	ElementId intersectingReference,
	double offset
)

Parameters

intersectingReference ElementId
Id of the new intersecting reference.
offset Double
The Offste for the new intersecting reference.

Return Value

Boolean
True if the PartMaker did not already use this intersecting reference and it was added, false if the PartMaker already used this intersecting reference and this call only updated its offset.
Exceptions
Exception Condition
ArgumentException The element id was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes.
ArgumentNullException A non-optional argument was null
See Also