GetTypeCatalogStringForUnit Method


Gets the string used in type catalogs to identify a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static string GetTypeCatalogStringForUnit(
	ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function GetTypeCatalogStringForUnit ( _
	unitTypeId As ForgeTypeId _
) As String
Visual C++
public:
static String^ GetTypeCatalogStringForUnit(
	ForgeTypeId^ unitTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DBForgeTypeId
Identifier of the unit.

Return Value

The type catalog string, or an empty string if the unit cannot be used in type catalogs.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also