Unit |
Gets the string used in type catalogs to identify a given unit.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- unitTypeId ForgeTypeId
- Identifier of the unit.
Return Value
StringThe type catalog string, or an empty string if the unit cannot be used in type catalogs.

Exception | Condition |
---|---|
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). |
ArgumentNullException | A non-optional argument was null |