AllowJoinAtEnd Method


Sets the indicated end of the framing element to be allowed to join to others.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static void AllowJoinAtEnd(
	FamilyInstance familyInstance,
	int end
)
Visual Basic
Public Shared Sub AllowJoinAtEnd ( _
	familyInstance As FamilyInstance, _
	end As Integer _
)
Visual C++
public:
static void AllowJoinAtEnd(
	FamilyInstance^ familyInstance, 
	int end
)

Parameters

familyInstance
Type: Autodesk.Revit.DBFamilyInstance
The FamilyInstance, which must be of a structural framing category.
end
Type: SystemInt32
The index of the end (0 for the start, 1 for the end).

Remarks

If that end is near other elements it will become joined as a result. By default all framing elements are allowed to join at ends, so this function is only needed if this element end is already disallowed to join.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException end must be 0 or 1.
Autodesk.Revit.ExceptionsArgumentsInconsistentException The input familyInstance is not of a structural framing category.

See Also