Structural |
Sets the indicated end of the framing element to be allowed to join to others.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- familyInstance FamilyInstance
- The FamilyInstance, which must be of a structural framing category.
- end Int32
- The index of the end (0 for the start, 1 for the end).

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | end must be 0 or 1. |
ArgumentsInconsistentException | The input familyInstance is not of a structural framing category. |

If that end is near other elements it will become joined as a result. By default all framing elements are allowed to join at ends, so this function is only needed if this element end is already disallowed to join.