InitialWattageIntensity Constructor (Double, Double)


Creates an initial wattage intensity object with the given values.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public InitialWattageIntensity(
	double efficacy,
	double wattage
)
Visual Basic
Public Sub New ( _
	efficacy As Double, _
	wattage As Double _
)
Visual C++
public:
InitialWattageIntensity(
	double efficacy, 
	double wattage
)

Parameters

efficacy
Type: SystemDouble
The universal unit efficacy value as a numerical value between 0 and 1e+30.
wattage
Type: SystemDouble
The universal unit wattage value as a numerical value between 0 and 1e+30.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The efficacy value is not valid because it is not between 0 and 1e+30. -or- The wattage value is not valid because it is not between 0 and 1e+30.

See Also